Commit 1b0bc2e0 authored by Lukas Reschke's avatar Lukas Reschke
Browse files

PHP 5.4 is now required for master

🍻
parent 8700ffe6
......@@ -605,9 +605,9 @@ class OC_Util {
$webServerRestart = true;
}
if (version_compare(phpversion(), '5.3.3', '<')) {
if (version_compare(phpversion(), '5.4.0', '<')) {
$errors[] = array(
'error' => $l->t('PHP %s or higher is required.', '5.3.3'),
'error' => $l->t('PHP %s or higher is required.', '5.4.0'),
'hint' => $l->t('Please ask your server administrator to update PHP to the latest version.'
. ' Your PHP version is no longer supported by ownCloud and the PHP community.')
);
......@@ -1113,15 +1113,6 @@ class OC_Util {
return function_exists('finfo_open');
}
/**
* Check if a PHP version older then 5.3.8 is installed.
*
* @return bool
*/
public static function isPHPoutdated() {
return version_compare(phpversion(), '5.3.8', '<');
}
/**
* Check if the ownCloud server can connect to the internet
*
......
......@@ -38,7 +38,6 @@ $template->assign('isLocaleWorking', OC_Util::isSetLocaleWorking());
$template->assign('isPhpCharSetUtf8', OC_Util::isPhpCharSetUtf8());
$template->assign('isAnnotationsWorking', OC_Util::isAnnotationsWorking());
$template->assign('has_fileinfo', OC_Util::fileInfoLoaded());
$template->assign('old_php', OC_Util::isPHPoutdated());
$template->assign('backgroundjobs_mode', $appConfig->getValue('core', 'backgroundjobs_mode', 'ajax'));
$template->assign('cron_log', $config->getSystemValue('cron_log', true));
$template->assign('lastcron', $appConfig->getValue('core', 'lastcron', false));
......@@ -81,7 +80,7 @@ $l = OC_L10N::get('settings');
$formsAndMore = array();
if (OC_Request::serverProtocol() !== 'https' || !$htAccessWorking || !OC_Util::isAnnotationsWorking() ||
$suggestedOverwriteWebRoot || !OC_Util::isSetLocaleWorking() || !OC_Util::isPhpCharSetUtf8() ||
OC_Util::isPHPoutdated() || !OC_Util::fileInfoLoaded() || $databaseOverload
!OC_Util::fileInfoLoaded() || $databaseOverload
) {
$formsAndMore[] = array('anchor' => 'security-warning', 'section-name' => $l->t('Security & Setup Warnings'));
}
......
......@@ -153,20 +153,6 @@ if (!$_['has_fileinfo']) {
<?php
}
// is PHP at least at 5.3.8?
if ($_['old_php']) {
?>
<div class="section">
<h2><?php p($l->t('Your PHP version is outdated'));?></h2>
<span class="connectionwarning">
<?php p($l->t('Your PHP version is outdated. We strongly recommend to update to 5.3.8 or newer because older versions are known to be broken. It is possible that this installation is not working correctly.')); ?>
</span>
</div>
<?php
}
// is PHP charset set to UTF8?
if (!$_['isPhpCharSetUtf8']) {
?>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment